Пишу про разработку вообще и в частности про: JavaScript, HTML5, CSS3, AngularJS, ReactJS, Agile.

И снова обновляю версии в проекте на реакте

Стандартная ситуация – обновляем версии в достаточно большом проекте и начинаем тихо материться. Сколько же успевают обновить и сколько переписать. Фронтенд он такой фронтенд. Обычно я начинаю с самых простых пакетов и не спеша поднимаюсь к основным библиотекам. babel babel-preset-latest (или babel-preset-es2015, babel-preset-es2016, и babel-preset-es2017 вместе) – все это теперь деприкейтед. Вместо них просто используем

Настройки для обработки ошибок gulp-less, gulp-babel

Плагина для gulp’а не умет “из коробки” не падать в тот момент как натыкаются на ошибку – это нужно настраивать самому. Как вариант можно просто продолжать перезапускать сборку, но это уж очень грустно, по-этому давайте посмотрим как уменьшить боль. gulp-babel Для начала потребуются вот эти npm пакеты: Последний нужен, чтобы “все было симпатично”. А

Конфигурация gulpfile для проекта на ReactJS и ES6 (ES2015)

Для создания проекта с использованием ReactJS и написанием всех компонентов в новом синтаксисе ES6 (ES2015) нам потребуется использовать менеджер Gulp. Вместо него, в принципе подойдет любой другой, который вам знаком, основные принципы останутся те же. Для начала, скажу, что я исхожу из предположения, что вы уже работаете с gulpfile’ом на ES2015. Если нет, то посмотрите